This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gdb 7.11.1-2 started within emacs fails

On 10/11/2017 3:44 PM, Jon Turney wrote:
On 27/09/2016 21:15, Ken Brown wrote:
On 9/27/2016 2:47 PM, Rockefeller, Harry wrote:
Using program foo:
      program foo
      e = 1.0

$ /usr/bin/gfortran    -g foo.f -o foo

Emacs version info: GNU Emacs 25.1.1 (i686-pc-cygwin, GTK+ Version 3.18.9) of 2016-09-17

Inside emacs I ran M-x gud-gdb and got
... GNU gdb (GDB) (Cygwin 7.11.1-2) 7.11.1 ...
(gdb) b 1
Breakpoint 1 at 0x4011d6: file foo.f, line 1.
(gdb) r
Starting program: /cygdrive/c/Users/harryr/foo.exe
[New Thread 6296.0x22ac]
[New Thread 6296.0x24d4]
readline: readline_callback_read_char() called with no handler!
Debugger aborted (core dumped)

Foo written in C++ also fails with the same message.
Running gdb foo in bash gives the expected result:
gdb stops at first executable line prompting for next gdb command.

I can confirm that this happens also with gdb-7.11.1-1 but not gdb-7.10.1-1.  (I tested on x86_64, since gdb-7.10.1-1 is broken on x86.)

It also fails with M-x gdb instead of M-x gud-gdb, but with a different error message:

   Failed to resume program execution (ContinueDebugEvent failed, error 87)

These problem seem not longer occur due to upstream changes in gdb 7.12.

Everything seems fine on x86_64 and with M-x gud-gdb on x86. But when I run M-x gdb on x86 (even with no file), gdb crashes.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]