This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Sudden, unexplained failure of ssh

On 2018-02-22 09:56, wrote:
> I've been running 2.9.x under windows 7 on my 16GB laptop for a long time (probably the 
> last year), when late last week my ssh outbound quit working.  The failure is indicated with 
> this error message:
> ssh: Could not resolve hostname Non-recoverable failure in name resolution
> I checked the forums, and what I saw seemed to relate to connecting to VM boxes.
> In my case, this is not the cause of the failure.
> This machine is my company provided (and software managed) laptop, so I don't have a 
> lot of control over (in fact, I don't have hardly any control) what gets "pushed" to it.
> However, the one thing that I noticed that seemed to coincide with the failure is that
> the company pushed an "Elastica Reach Agent 1.0.20930.0" to my machine.

Another poorly written cloud "security"/intercept/monitor BLODA app; see:

appears to be interfering with resolving.
Try "cygcheck ssh wget" to see if non-Cygwin non-Windows DLLs are in your PATH,
remove those directories from your Cygwin PATH, and retry to see if that helps.
Use host/nslookup/dig to get the IP address, and retry using that instead of the
host name, to bypass the resolver, and see if that helps.
See if you can add a bypass in the product for ssh and wget, or have your admins
do so, and report the problem to the vendor.

> I thought the issue might have been a version problem, so I updated to the latest 
> Cygwin version
> $ uname -a
> CYGWIN_NT-6.1 TCO10106LKVTAHB 2.10.0(0.325/5/3) 2018-02-02 15:16 x86_64 Cygwin
> That didn't fix the problem.  I've also tried some other utilities,  which are working, 
> such as mobaxterm(Cygwin based), babun(Cygwin based)  and putty.  All those seem to work
> fine.
> Once I determined that it wasn't my actual network stack, I then tried running ssh under
> strace, and now it works.  So, I can use ssh if I use it with strace, but natively by itself
> it continues to get the failure in name resolution.
> Any clues, hints or pointers on how to go about either determining what the problem is, or 
> how to clean it up?
> (I am also seeing the same issue with wget, and strace clears that up also
> $ wget
> --2018-02-22 09:55:38--
> Resolving ( failed: Non-recoverable failure in name resolution.
> wget: unable to resolve host address ''

You could try running ssh and wget with debugging options to see if that
bypasses the problem similar to running under strace.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]