This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Printing (lpr, print, cat > <various names> returns printer not valid or no longer available

Greetings, Rodney Barnhart!

Please no top-posting in this list.
See , also

> Andrey,
> Thanks for responding.
> I have to apologize in advance. I don't know the answer to your question.

You can find it by using the usual means.

$ which <program>

will tell you, what is the actual path it is using currently.

> It's the lpr that executes under the bash system once CYGwin starts. I did a
> search for lpr.exe under windows and found one under an obscure windows
> directory. When I tried to execute it said it can't run on my PC? Windows
> doesn't seem to have a native lpr?

It should, if printer monitor service is installed.
Does not mean it will be an equal substitution.

> I don't know how to find the Cygwin lpr that I'm using. I remind you that
> print, catting to $PRINTER don't work either.
> If you tell me how I'll find which lpr is running under bash in Cygwin.

Did you "find" it in WinSxS cache?

It was a long time since I last tried smth like this, but I can replicte your
issues. Even if the job was sent to printer, it results in error.
On another hand, running text files trough

convert text:... pdf:- | lpr -lP '//$HOSTNAME/Device'

did produce some usable results. With PDFCreator.
It appears, the data sent to the printer must be understood by the printer

With best regards,
Andrey Repin
Friday, February 23, 2018 16:06:08

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]