This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: unable to map cygSDL error

On 6/22/2018 1:02 PM, massimiliano wrote:
Ken Brown-6 wrote
On 6/14/2018 11:22 AM, Massi Alvioli wrote:

As you mention in your post, I ran into the same problem:

so I would like to know if you can help me solve the problem.

Until someone figures out the underlying cause of the "unable to map"
error for cygSDL*.dll, my only suggestion is to try to work around the
problem as I did for gimp: avoid using SDL.  In your case, I think SDL
is brought in via the package libwx_gtk3u3.0_0.  If you look at the
source for that package, you'll see that it uses the configure option
--with-sdl.  So you could try to rebuild it without that option.

Hi Ken,

I tried to compile the libwx_gtk3u3.0_0 package: I installed the package
source using cygwin's setup, then cd /usr/src/wxWidgets3.0-3.0.3-1.src,
edited wxWidgets3.0.cygport to remove --with-dsl, and issued the commands
cygport wxWidgets3.0.cygport prep/compile/test/install. After installing
loads of new cygwin packages required to build wxwidgets, I compiled
GRASS GIS again but still I have no luck - same "unable to map
error message at startup.

Is there any obvious flaw in my procedure? any other idea?

Two things:

1. --with-sdl occurs twice in the .cygport file. Be sure to remove both occurrences.

2. Running 'cygport wxWidgets3.0.cygport prep/compile/test/install' is not enough. The 'install' part of this uses a destination directory 'inst' in the work directory created by cygport. You also have to run 'cygport wxWidgets3.0.cygport package', which creates several package tarballs in the 'dist' directory. The best way to proceed from there is explained in

under "Creating an overlay Cygwin package server". If you use this method, then you'll have to bump the release number in the .cygport file so that setup will recognize that there's a new version of libwx_gtk3u3.0_0.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]