This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Fork issue on W10 WOW

On 6/30/2018 11:52 AM, Marco Atzeri wrote:
on a new W10 HP Laptop, the 32 bit installation always fails
on postinstallation scripts that use perl.

The outcome is like:

$ ./
      1 [main] perl 1796 child_info_fork::abort: address space needed by 'Encode.dll' (0x2620000) is already occupied
Can't fork, trying again in 5 seconds at /usr/bin/fmtutil line 73.

Until I have the 32bit running I can not deploy any new package, as the previous W7 is retired.

I've never had this problem with my own 32bit installation on W10, but I just reproduced it by doing a new installation with your list of packages. Have you tried just installing a minimal list of packages that you need for building the packages you maintain?

Alternatively, you might work around the problem by first doing a base install, then installing your texlive-collection-* packages, and then installing everything else. I just tested this with your list of packages, and it worked for me.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]