Updated: openssl-0.9.8o-2

Corinna Vinschen corinna-cygwin@cygwin.com
Thu Jun 24 08:28:00 GMT 2010


I've updated the version of OpenSSL to 0.9.8o-2.  This also includes the
openssl-devel packages and, that's NEW, the libopenssl098 package!

In the first place this update introduces a change in the packaging
scheme of openssl.  The base package does not contain the runtime
libraries anymore, rather they are now in the libopenssl098 package.

This allows easier upgrading to the next version of openssl, 1.0.0a-1,
which will introduce partially backward incompatible libraries.  

This update also introduces new functionality:

- Support for the MDC-2 hash function.  This wasn't included so far for
  patent reasons, but even in the worst case the U.S. patent has expired
  in March 2010.
  
- The long outstanding support for Zlib compression.


To update your installation, click on the "Install Cygwin now" link on
the http://cygwin.com/ web page.  This downloads setup.exe to your
system.  Then, run setup and answer all of the questions.


*** CYGWIN-ANNOUNCE UNSUBSCRIBE INFO ***

If you want to unsubscribe from the cygwin-announce mailing list, look
at the "List-Unsubscribe: " tag in the email header of this message.
Send email to the address specified there.  It will be in the format:


cygwin-announce-unsubscribe-you=yourdomain.com@cygwin.com

If you need more information on unsubscribing, start reading here:

http://sourceware.org/lists.html#unsubscribe-simple

Please read *all* of the information on unsubscribing that is available
starting at the above URL.

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat



More information about the Cygwin-announce mailing list