[calm - Cygwin server-side packaging maintenance script] branch master, updated. 20221205-4-g8413b76

Jon Turney jturney@sourceware.org
Mon Jan 2 16:54:06 GMT 2023




https://sourceware.org/git/gitweb.cgi?p=cygwin-apps/calm.git;h=8413b769e25cd02472b14f11fc41e00d642c9028

commit 8413b769e25cd02472b14f11fc41e00d642c9028
Author: Jon Turney <jon.turney@dronecode.org.uk>
Date:   Mon Jan 2 14:50:41 2023 +0000

    Tweak SOVERSION_PACKAGE_RE so it matches solib packages without a number
    
    'libflint' and 'libturbojpeg' packages were mistakenly first made as
    solib packages without a soversion number.  Explicitly match them so
    they get treated as old solibs

https://sourceware.org/git/gitweb.cgi?p=cygwin-apps/calm.git;h=db46667e54cba9aae167c633e90ab228bd920723

commit db46667e54cba9aae167c633e90ab228bd920723
Author: Jon Turney <jon.turney@dronecode.org.uk>
Date:   Wed Dec 14 13:27:17 2022 +0000

    Revert "Pin flake8 before 6.0, as it's incompatible with current flake-import-order"
    
    This reverts commit 1d345508ee7ed441330da4a9810f21af216c6e58.


Diff:
---
 calm/calm.py             | 2 +-
 calm/common_constants.py | 2 +-
 calm/past_mistakes.py    | 2 --
 calm/reports.py          | 2 +-
 requirements.txt         | 2 +-
 5 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/calm/calm.py b/calm/calm.py
index 173fe47..dc66926 100755
--- a/calm/calm.py
+++ b/calm/calm.py
@@ -735,7 +735,7 @@ def main():
     parser.add_argument('--stagingdir', action='store', metavar='DIR', help="automated build staging directory (default: " + stagingdir_default + ")", default=stagingdir_default)
     parser.add_argument('--no-stale', action='store_false', dest='stale', help="don't vault stale packages")
     parser.set_defaults(stale=True)
-    parser.add_argument('--reports', action='store_true', dest='reports', help="don't produce reports", default=None)
+    parser.add_argument('--reports', action='store_true', dest='reports', help="produce reports (default: off unless daemonized)", default=None)
     parser.add_argument('-n', '--dry-run', action='store_true', dest='dryrun', help="don't do anything")
     parser.add_argument('--vault', action='store', metavar='DIR', help="vault directory (default: " + vault_default + ")", default=vault_default, dest='vault')
     parser.add_argument('-v', '--verbose', action='count', dest='verbose', help='verbose output')
diff --git a/calm/common_constants.py b/calm/common_constants.py
index a000588..5adfe91 100644
--- a/calm/common_constants.py
+++ b/calm/common_constants.py
@@ -91,4 +91,4 @@ PACKAGE_COMPRESSIONS_RE = r'\.(' + '|'.join(PACKAGE_COMPRESSIONS) + r')'
 # inspecting the contents (but that's expensive to do). for the moment, we
 # recognize soversion packages by the simple heuristic of looking at the package
 # name
-SOVERSION_PACKAGE_RE = r'^(lib|girepository-).*[\d_.]+$'
+SOVERSION_PACKAGE_RE = r'^(lib|girepository-).*[\d_.]+$|^libflint$|^libturbojpeg$'
diff --git a/calm/past_mistakes.py b/calm/past_mistakes.py
index e338c53..0edf8ba 100644
--- a/calm/past_mistakes.py
+++ b/calm/past_mistakes.py
@@ -84,12 +84,10 @@ nonunique_versions = [
     'kexi',                       # split out from calligra
     'kfilereplace',               # split out from kdewebdev
     'libcaca-doc',                # dropped pending fix for current doxygen
-    'libflint',                   # no number means it isn't considered an old soversion
     'libfltk-doc',
     'libgcj-common',              # dropped from gcc 6
     'libical_cxx-devel',
     'libquota-devel',             # no longer provided by e2fsprogs
-    'libturbojpeg',               # no number means it isn't considered an old soversion
     'libtxc_dxtn',                # split out from s2tc
     'mingw64-i686-poppler-qt4',   # dropped since 0.62.0
     'mingw64-i686-spice-gtk2.0',  # gtk2 dropped from spice-gtk
diff --git a/calm/reports.py b/calm/reports.py
index 2eb1455..3932d78 100644
--- a/calm/reports.py
+++ b/calm/reports.py
@@ -173,7 +173,7 @@ def deprecated(args, packages, reportsdir):
     body = io.StringIO()
     print(textwrap.dedent('''\
     <p>Packages for old soversions. (The corresponding source package produces a
-    newer soversion, or has stopped producing this soversion).</p>'''), file=body)
+    newer soversion, or has stopped producing this solib).</p>'''), file=body)
 
     print('<table class="grid">', file=body)
     print('<tr><th>package</th><th>version</th><th>timestamp</th><th>rdepends</th></tr>', file=body)
diff --git a/requirements.txt b/requirements.txt
index a172a9d..b75566e 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,4 +1,4 @@
-flake8<6
+flake8
 flake8-blind-except
 flake8-bugbear ; python_version >= "3.5"
 flake8-builtins



More information about the Cygwin-apps-cvs mailing list