[calm - Cygwin server-side packaging maintenance script] annotated tag 20230209, created. 20230209

Jon Turney jturney@sourceware.org
Thu Feb 9 15:50:50 GMT 2023


        at  282fac17ef8c49680409ecfdbbcfd6f33f6f14d8 (tag)
   tagging  d64ec03daa585e6df68b72b45e98c96ecc703241 (commit)
  replaces  20221205
 tagged by  Jon Turney
        on  Thu Feb 9 15:50:44 2023 +0000


20230209
-----BEGIN PGP SIGNATURE-----

iQIcBAABAgAGBQJj5RZUAAoJEMfIbwNwKFyB1rkP/Rlt8KYF1kYM00bThhXt/7V4
fIszujiqzQPv/v/fYQomCPuWptQ4dYEEyeH0Zh7xN8277pgxpuzcETshFPNu0376
6GvfY1aKaYgpIfrViwY0AyLJ+9WmGZbUhp6/sWUXMqI2A7koiGWiD+FRi2ZjUjcv
UVzpj55IHDHc0RuQSFCmUfhvdJ6WbzmA5O2ubMmy9nJG1rTcdg9CxmssG5muGhjn
tNA8ogic78bD+04rqko7UtFLAuL8Bsj8eo+EXiG1R9AeS7t8pf/EptVKu7lzaaII
OzhvtHze8HH7IBZ/MQKOT5OufIRbfyjHjVXExw4cWNc/IJaVcxdmqSvYyx7rzdTG
hEqYyCul59ZVafiyxGhZWopIC7l4U2yiDYrLefXbPau+mhV72Tco4NGwGljSN3u8
UrHJmVVBlwOg2CT6ECJrF9TO05VKMRQsDgb1OPxnAv2zV8UjHbnOgAUUb1zpEBNp
GiMHCvDMzSTOCWehDL2ubhzbNuouCl6uVaIAS6FJUSxFRrHUzJytxG6pggCZuaQc
KItSZtssN7zOUXrFbKk88RnfUqjO2yenGJVVvNFphiYqA0rzIcXAVU143Qlqezae
e5PS28HQyqSVeaFD9VXIWkJh+F5frHGeGO+jh9OHX+zECCXpp9mwN7Uq571ngntJ
uirI6I7LBWHuS7WcmAHR
=irg4
-----END PGP SIGNATURE-----

Jon Turney (33):
      Add a simple wrapper for caching a parsed file until mtime changes
      Treat sha512.sum as a cache for sha512 computation
      Revert "Pin flake8 before 6.0, as it's incompatible with current flake-import-order"
      Tweak SOVERSION_PACKAGE_RE so it matches solib packages without a number
      Drop special case to handle libturbojpeg as a solib package
      CI: Update deprecated GitHub actions
      Allow an empty source for obsoleted catgets package
      Allow package version to be marked as weakly retained
      Finish data for old_style_obsolete_by heuristic
      Rename old-style obsoletion conversion threshold for clarity
      Don't warn about obsoletion with no replacement for packages marked self-destruct
      Don't convert blacklisted old-style obsoletes: to new-style
      Don't synthesize a new-style obsolete when current version isn't obsolete
      Allow regex matching for old_style_obsolete_by data
      Recursively apply missing obsoletes
      Look for multiple obsoletes of the same package
      Add a more generic 'add requires based on paths in package' tool
      Add 'python26' to non-existent provide list
      Add expiry based on obsolete, removed provides
      Expire packages which require non-existent python26
      Check for forbidden hyphen-digit sequence in package name
      Validate character set used by the package version, V
      Only allow requires: of packages which currently exist
      Remove obsolete 'mkmaintdir' tool
      Add 'calm-tool vault'
      Relax trusted maintainer restrictions
      Propagate any error reading packages through mksetupini
      Don't add duplicate license keys
      Drop a spurious argument to maintainers.add_packages()
      Fix inverted logic in mksetupini error propagation
      Add a little success feedback to vault command
      Add 'OFSFDL' to additional license ids list
      Update version to 20230209





More information about the Cygwin-apps-cvs mailing list