a2ps compile problem against 1.5.2

Gerrit P. Haase gp@familiehaase.de
Mon Aug 18 23:00:00 GMT 2003

Hallo Nicholas,

Am Montag, 18. August 2003 um 23:48 schriebst du:

>>>>My solution was to get rid of -lm.\

>>>This is not a solution.  It is a workaround.

>> Ok.  I see the problem.  I'm still puzzling over how to fix it.  I think
>> it is arguably a bug in ld but that's really not a big help to know.  I
>> have to fix it either way.

> Perhaps a refresh of the latest binutils against 1.5.2 might be a good 
> idea anyways.  Ditto for gcc.

I did this already (I compiled binutils, cygwin and gcc-3.3.1), I got
the same problem with the version of cygwin/libm.a as taken from cvs
about the same time as Christopher created the 1.5.2 test release and
I compiled the binutils snapshot from the same day.  There were no
problems with winsup & binutils source some days before the libc.a
problem was discovered (the days I tried to get perl to compile where
I hit the libc.a bug because I linked against both, libc.a and libm.a
which worked in the link stage but it failed to run the executable

What is on my todo list now is to recompile cygwin & binutils with

Anyway, I like gcc-3.3.1, works like a champ for me.  But wait until
Danny Smith releases the final MinGW version, he sent me an updated
cygwin.h file recently, so he's probably still working on it.  That is
the reason why recompiling gcc is also on my todo list (now the top


More information about the Cygwin-apps mailing list