Serious error compiling setup

Brian Keener
Thu Jan 30 16:41:00 GMT 2003

Max Bowsher wrote:
> > When I try to compile setup I get the following:
> > 
> > + /usr/develop/src/cygwin-apps/setup/configure -C
> > --enable-dependencies --disable-shared --host=i686-pc-mingw32 
> > --build=i686-pc-cygwin CC=gcc -mno-cygwin CXX=g++ -mno-cygwin 
> > CPPFLAGS=-I/usr/include/g++-3 --enable-maintainer-mode
> Drop the CPPFLAGS bit, that dates back to gcc-2.95.3


> > checking for C++ compiler default output... configure: error: C++
> > compiler cannot create executables
> gcc-mingw package?

Yes but i have reinstalled it and gcc several times and still no better

> > check `config.log' for details.
> Well?

See below

> > In addition to the above I also receive while compiling setup a
> > dialog box titled 16bit MS-DOS SubSystem with the message:
> > g++
> > The NTVDM CPU has encountered an illegal instruction.
> > CS:067f IP:017d OP:ff ff 75 13 8b CHoose 'Close' to terminate the
> > application. 


> > Having failed with setup I decided to try to compile cygwin I there I
> > get the following error:
> > 
> > + /usr/develop/src/configure --enable-debugging --build=i686=pc-cygwin
> > --target=i686-pc-cygwin --enable-haifa --prefix=/usr --exec-prefix=/usr
> > --sysconfdir=/etc --libdir=/usr/lib --includedir=/nonexistent/include
> > configure: error: cannot run /bin/bash /usr/develop/src/config.sub
> How about some elementary troubleshooting of the error? 
> Like: Does it exist, check permissions?

This was the result of a bad merge that I missed the result .# File on.  I 
usually check for these.  In this case the merge code was still there along 
with some other files that still had merge code.  I cleaned them up, still 
could not get to compile and reinstalled gcc and gcc-mingw and deleted all my 
source config* files and Make* files and reupdated from cvs to get them back.  
Still no luck.

When I try to configure setup (not build, just  configure) I get this on the 
screen still even after the above:

+ /usr/develop/src/cygwin-apps/setup/configure -C --enable-dependencies 
e-shared --host=i686-pc-mingw32 --build=i686-pc-cygwin CC=gcc -mno-cygwin 
+ -mno-cygwin --enable-maintainer-mode
configure: loading cache config.cache
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for i686-pc-mingw32-strip... no
checking for strip... strip
checking whether to enable maintainer-specific portions of Makefiles... yes
checking Whether to build inilint... no
checking Whether to enable rsync support... no
checking for i686-pc-mingw32-g++... g++ -mno-cygwin
checking for C++ compiler default output... configure: error: C++ compiler 
t create executables
check `config.log' for details.

In checking the config.log now it would appear the pertinent part is:

configure:2044: checking for C++ compiler default output
configure:2047: g++ -mno-cygwin  >&5
g++: installation problem, cannot exec 
./../../i686-pc-mingw32/bin/ld.exe': Invalid argument
configure:2050: $? = 1
configure: failed program was:
#line 2027 "configure"
#include "confdefs.h"

main ()

  return 0;
configure:2077: error: C++ compiler cannot create executables
check `config.log' for details.

Yes i686-pc-mingw32 exists and contains 3 directories which are linked to other 
directories.  The bin directory is linked to ../i686-pc-cygwin/bin and in this 
directory there is an ld.exe and all users have execute privilige.

When I try to configure the build for cygwin (not even build it) I get this on 
the screen:

+ /usr/develop/src/configure --enable-debugging --host=i686-pc-cygwin 
86-pc-cygwin --target=i686-pc-cygwin --enable-haifa --prefix=/usr 
/usr --sysconfdir=/etc --libdir=/usr/lib --includedir=/nonexistent/include
loading cache ./config.cache
checking host system type... i686-pc-cygwin
checking target system type... i686-pc-cygwin
checking build system type... i686-pc-cygwin

and the process hangs.  If I check the Process stack from another window 
running rxvt and a bash shell I get this:

$ ps -ef 
  briank    1328       1   1  11:06:30 /usr/bin/bash
  BrianK     584       1   0  11:06:22 /usr/bin/rxvt
  briank    1692     584   2  11:06:35 /usr/bin/bash
  briank    1780    1328   1  11:06:44 /usr/bin/sh
  briank    1800    1780   1  11:06:45 /usr/bin/sh
  briank    1828    1800   1  11:06:56 /usr/bin/gcc
  briank    1900    1828   1  11:06:57 /usr/i686-pc-cygwin/bin/as
  briank    1412    1692   2  11:14:01 /usr/bin/ps

The above I have to kill manually and if I check the config.log I simply see 
the following:

$ less config.log
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:578: checking host system type
configure:599: checking target system type
configure:617: checking build system type
config.log (END)

 Thanks for any assistance

More information about the Cygwin-apps mailing list