Possible bug in setup.exe 2.303 when downloading via ftp

Pavel Tsekov ptsekov@gmx.net
Fri Jan 31 10:07:00 GMT 2003


Yesterday I've tried to install Cygwin from scratch on Win2k Pro / SP3 
with the experimental setup 2.303. This was a fresh copy of Win2k, just 
installed on the machine, and next I've tried to install Cygwin. I chose 
'Install from Internet' and as a download site ftp://archive.progeny.com. 
On the package chooser screen I haven't touched anything i.e. I wanted 
only packages from Base to be installed. I've tried twice with the same 
settings and both tries were unsuccessful. What happens is that at some
point during the package download, setup would hang, when it reaches the 
last block of data for a given package i.e. it displays something like 
1005 of 1013 k. Ok, I launched a cmd window and typed 'netstat' - I saw 
the following:

rama.progeny.com:ftp   CLOSE_WAIT
rama.progeny.com:49984 ESTABLISHED

I left setup for several hours but nothing changed. It would just sit 
there and wait on that screen :)

If anyone is going to try to hunt this, please, try to connect to 
ftp://archive.progeny.com  - I suspect maybe it's something in the 
behaviour of their ftp server which fools setup.

More information about the Cygwin-apps mailing list