Please update: GMP 4.1.3 for Cygwin

Gerrit P. Haase
Fri Jun 4 12:08:00 GMT 2004

Hi Lapo,

>> I have uploaded the Cygwin version of GMP 4.1.3 now, do you want to
>> fetch my patch and try to rebuild?  I changed some parts of the
>> configuration stuff to enable autoreconf runs, so

> I have a big of problems understanding a patch that contains also
> autoreconf changes, but as my own release didn't have any patch at all
> except from some diffs directly from GMP webpage (that would be included
> in the version you used, I guess), I have no problems with that.

Have you tried to build the included examples?  It failed for me, I got
also undefined references when building smalltalk, therefore I changed
some details in the main, I thought the culprit was

@@ -292,9 +292,7 @@
 libmp_la_LIBADD = $(libmp_la_DEPENDENCIES)
 libmp_la_LDFLAGS = $(GMP_LDFLAGS) \
-  -export-symbols $(srcdir)/libmp.sym
 # Optional objects, listed in a dummy library to generate ansi2knr rules and
 # get them in "make dist".

Then I wanted to regen but I got errors when running
autoreconf --install --force --verbose.  So I changed the mpfr and the path in acinclude.m4 and now it works also to
reconfigure.  Since the autotools are sup to date there are lots of
changes in the generated/copied files.

>> it is needed to
>> extract the source from /usr/src to apply my patch without changes, else
>> you'll need to modify some hardcoded paths.

> Strange, the patch doesn't seems to contain absolute paths to me...

In acinclude.m4 and therefore they are also in aclocal.m4:

diff -urN -x .build -x .inst -x .sinst -x COPYING -x INSTALL gmp-4.1.3-orig/acinclude.m4 gmp-4.1.3/acinclude.m4
--- gmp-4.1.3-orig/acinclude.m4 2002-09-08 02:02:19.000000000 +0200
+++ gmp-4.1.3/acinclude.m4      2004-05-24 13:25:47.395788800 +0200
@@ -831,10 +831,10 @@
 [[\\/]]* | ?:[[\\/]]* )  tmp="$srcdir"    ;;
 *)                       tmp="../$srcdir" ;;
-echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4
+echo ["define(<CONFIG_TOP_SRCDIR>,</usr/src/gmp-4.1.3>)"] >>$gmp_tmpconfigm4
 # All CPUs use asm-defs.m4 
-echo ["include(CONFIG_TOP_SRCDIR\`/mpn/asm-defs.m4')"] >>$gmp_tmpconfigm4i
+echo ["include(/usr/src/gmp-4.1.3/mpn/asm-defs.m4)"] >>$gmp_tmpconfigm4i

>> There is one changed C file,
>> this is a patch from the GMP homepage.

> I guess you're talking about this one?

Yes, exactly.


More information about the Cygwin-apps mailing list