[ITP] gvim-6.4

Corinna Vinschen corinna-cygwin@cygwin.com
Sat Dec 24 12:52:00 GMT 2005

On Dec 23 13:14, Yaakov S (Cygwin Ports) wrote:
> >   Searching for "/home/corinna/.vim/after/bitmaps/FindHelp.bmp"
> >   not found in 'runtimepath': "bitmaps/FindHelp.bmp"Vim: Caught deadly signal SYS
> > 
> >   Writing viminfo file "/home/corinna/.viminfo"Vim: Finished.
> > 
> > However, I tried with a local Xming server, which worked fine.
> After some googling, I found that gvim relies on the internally compiled
> pixmaps by default when it doesn't find others to override them (e.g. if
> cream were being used), so these Searching messages are normal.
> Trying 'gvim -V' with Cygwin/X11 shows:
> Searching for "/home/Yaakov/.vim/after/bitmaps/FindHelp.bmp"
> not found in 'runtimepath': "bitmaps/FindHelp.bmp"
> C:\cygwin\bin\gvim.exe (5676): *** MapViewOfFileEx (0x19440000), Win32
> error 6.  Terminating.
>      16 [main] gvim 4696 fork_parent: child 5676 died waiting for dll
> loading
> But gvim does launch, of course.
> So it seems that gvim is sensitive to rebase issues (perhaps because
> gvim behaviour is to spawn to background, freeing up the command line
> without 'gvim &'); perhaps this happened to you as well, and Xvnc caught
> the MapViewOfFileEx error and misinterpreted it?

Xvnc can't catch the MapViewOfFileEx error since it's running on Linux.
Whatever is causing this message is running on the Cygwin side of

The error message you see points to the fact that apparently some part
of gvim or subsequent libraries use SYSV shared memory.  The reason you
see this error message and I see a SIGSYS is that I don't have
CYGWIN=server set in my environment by default and no cygserver is
running unless I'm debugging it.

So what we have here looks like something I don't like, which is, that
running gvim requires to run Cygserver because something, gvim itself or
some library, is using SYSV shared memory.  I don't think that should be
necessary, except in very trying cases like, say, a database like
postgresql.  So, whatever is using SYSV shared memory in this scenario,
it shouldn't.  The fact that I can start gvim on a local Xmingw server
but not on a remote X server shows, that SYSV shared memory can't be
a necessity.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

More information about the Cygwin-apps mailing list