[PATCH] generic-build-script

Max Bowsher maxb@ukf.net
Tue Jun 21 22:31:00 GMT 2005

Igor Pechtchanski wrote:
> On Tue, 21 Jun 2005, Harold L Hunt II wrote:
>> Max Bowsher wrote:
>> [...]
>>> Of course, normally these are the same, but in my case they are not.
>>> Therefore, the following patch changes all occurrences where ${BASEPKG} is
>>> used in the second sense to ${PKG}-${VER}, so that ${BASEPKG} may be
>>> redefined in my case.
>> [...]
>> Max,
>> My two cents:
>> Stick a comment above the definition for BASEPKG to explain the scenario
>> where BASEPKG and PKG-VER will be different... otherwise you'll get
>> dorks like me thinking that a patch reversing your patch would be
>> useful, and such a thing must just slip in by accident.  Of course, the
>> comment would also help maintainers figure out that this feature is
>> present and that they can use it.
>> Since I've not written three times more words that would be in such a
>> comment, I might as well give it a go:
>> # NOTE: BASEPKG is "name-version" of the upstream package.  Usually this
>> # is equal to ${PKG}-${VER}, except in the case where the Cygwin package
>> # name is different than the upstream package name (e.g. upstream:
>> # "foo-1.0" BASEPKG=foo-1.0, Cygwin package: "bar-1.0" PKG=bar VER=1.0).
>> Feel free to reword that.
> Good point, Harold.  In fact, looking at the ChangeLog, I was one of
> those dorks. :-)
> The easiest solution would probably be to define two variables, BASEPKG
> and ORIGPKG, and set them to the same value initially.  We'd still need a
> comment describing why there are two variables, and what ORIGPKG is useful
> for.
> If BASEPKG seems better for the upstream package name, I'm open to
> suggestions for the name of the variable containing the ${PKG}-${REL}
> combo.

Hmm. It seemed sort-of elegant to me to just use ${PKG}-${VER}, rather than defining another variable.
I'd go with just a comment.

If not, how about names:






More information about the Cygwin-apps mailing list