Anyone looking at the 'setup.exe' 2.510.2.1 crashing problem?

Dave Korn
Thu Sep 8 15:27:00 GMT 2005

----Original Message----
>From: Christopher Faylor
>Sent: 08 September 2005 16:18

> This doesn't seem to be a problem with the package database.  You can
> add a "umount --remove-all-mounts" to the above, choose a different root
> during installation and still get the same result.

  It's a bogus lookup in the stl_ stuff while finding the source packages in
packagemeta::ScanDownloadedFiles, and when we call pkgsrcver.scan, the first
thing that tries is "if (!*this)", which works like this:

packageversion::operator ! () const
  return !data->Name().size();

and for some reason, when we try to look up data->Name(), we jump into
space.  Since _packageversion::Name is a virtual function, I suspect that
something that isn't really a packageversion has gotten into the vector in
packagemeta::ScanDownloadedFiles, and it's being masked by the

  Or perhaps that "__result may be used uninitialised" warning in the stl
stuff is for real after all, and the iterator is actually returning an
uninitialised value.

  I haven't got any further than that yet, because it was my lunch hour, and
it came to an end....

Can't think of a witty .sigline today....

More information about the Cygwin-apps mailing list