CVS setup.exe crashes on Windows 2003 Server x64

Thrall, Bryan
Fri Dec 15 21:08:00 GMT 2006

I'm seeing setup.exe built from CVS head crash on Windows 2003 Server
x64 (Standard version, SP 1). I tried running setup.exe in WinXP
compatibility mode and that didn't help; running as an unrestricted user
didn't help either. The user I'm running as is an Administrator.

I get the following backtrace when I run setup.exe in gdb:

Starting program: /cygdrive/d/setup.exe 
Error: dll starting at 0x78d41000 not found.

Error: dll starting at 0x78d41000 not found.

Error: dll starting at 0x78c31000 not found.

warning: LOG: 2 Starting cygwin install, version 2.551 VSS Special
warning: LOG: 2 Current Directory:

Program received signal SIGSEGV, Segmentation fault.
0x004eb157 in AllocateAndInitializeSid@44 ()
(gdb) bt
#0  0x004eb157 in AllocateAndInitializeSid@44 ()
#1  0x0043d8f8 in NTSecurity::initialiseEveryOneSID (this=0x23f780)
#2  0x0043daca in NTSecurity::setDefaultDACL (this=0x23f780) at
#3  0x0043e1ec in NTSecurity::setDefaultSecurity (this=0x23f780) at
#4  0x0043ed33 in set_default_sec () at
#5  0x0043f3a2 in WinMain (h=0x400000, hPrevInstance=0x0, 
    command_line=0xe0245d "", cmd_show=10) at
#6  0x00499238 in main (argc=1, argv=0x346b8, __p__environ=0x33090)
    at ../../runtime/main.c:73

After a little debugging, it looks like the this pointer is getting
corrupted between frames 1 and 0 (it is valid in frame 1 and invalid --
0x105 IIRC -- in frame 0).

Setup.exe 2.510.2.2 works just fine.

cygcheck output attached for the machine I'm building setup.exe on.

Any suggestions on what might be going wrong? Can anyone else reproduce

Bryan Thrall
FlightSafety International 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 45846 bytes
Desc: cygcheck.out
URL: <>

More information about the Cygwin-apps mailing list