[ITP] PHP 5.1.4 (cli, cgi-fcgi, apache2) [re-issued]

Lapo Luchini lapo@lapo.it
Sun Dec 17 11:09:00 GMT 2006

Max Bowsher wrote:
> There was one additional fix I had made locally but got around to
> updating the tarballs on my server
OK, thanks =)

BTW: have you had this problem? and you solved it how?

% ./php-5.2.0-0.1.sh install strip pkg spkg
Installing PHP SAPI module:       apache2handler
SH_LIBTOOL='/usr/share/apr-1-build/libtool' libphp5.la
/usr/share/apr-1-build/libtool --mode=install cp libphp5.la
libtool: install: error: cannot install `libphp5.la' to a directory not
ending in /home/lapo/packaging/tmp/php-5.2.0/.build/libs
apxs:Error: Command failed with rc=65536

I noticed that to create shared extension --enable-shared is needed in
conf(), but it does seem to create the libphp5.la shared nonetheless,
and libtool gives that error, which I didn't understand very well but
(googling a bit) I guess it's about relinking and it's not about to be
solved. ?_?


More information about the Cygwin-apps mailing list