rsync changed ACL behaviour?

Christopher Faylor
Sun Sep 17 22:13:00 GMT 2006

On Sun, Sep 17, 2006 at 07:37:35PM +0200, Mattias wrote:
>Using rsync to update my web site on a Windows 2003 Server using the
>following command
>rsync --archive --stats /cygdrive/c/data/publish/ -e ssh
>Worked fine for a year.
>Stopped working recently. rsync doesn't set the ACL correctly. rsync
>sets the rights of the Users user to nothing at all,
>which makes the web site not work at all. (I have switched my laptop
>since it last worked and reinstalled cygwin.)
>After running rsync, I have to go to the server, opening the security
>dialog for the directory, pressing advanced, selecting
>"Replace permission entries on all child objects with enties shown
>here that apply child objects"
>These are the default permissions, so why doesn't rsync use them.
>Which permissions do rsync use?
>P.s. Is there a simple way in cygwin setup.exe to just revert to an
>older version of a single package, in my case rsync  2.6.3?

Please go back and read again.  This is not
a bug reporting mailing list or a list for asking about usage questions.

Please use the main cygwin mailing list for that.

More information about the Cygwin-apps mailing list