Problems with cygport 2.8-1?

Dave Korn
Fri Jan 19 14:54:00 GMT 2007

On 19 January 2007 14:41, Chris Sutcliffe wrote:

> Hey All,
> I'm trying to package astyle 1.20 and I've run in to a snag.  When
> executing cygport I get:
> $ cygport astyle-1.20-1.cygport all
>>>> Preparing astyle-1.20-1
> *** Info: gnupg must be installed in order to check signatures.
>>>> Unpacking source astyle_1.20_linux.tar.gz
>>>> Preparing working source directory
> *** ERROR: patch astyle-1.20-1.cygwin.patch will not apply
> I did the normal diff -urN to create the patch.  Out of interest, I
> tried the astyle-1.19-1 files which I used to create the 1.19-1
> package using cyport 2.7 with cygport 2.8 and I got the same error.
> Do I need to produce the patch in a different format, or is this a bug in
> 2.8? 

  Well, try applying the patch manually and see if there are any .rej hunks
left over afterward.  If there are, cygport has correctly reported a problem
with the patch.  If there aren't, cygport has a bug.

Can't think of a witty .sigline today....

More information about the Cygwin-apps mailing list