setup-1.7 can't be used to update, only install

Charles Wilson
Sat May 3 00:04:00 GMT 2008

I followed the instructions here:
when I initially installed cygwin-1.7 alongside my existing cygwin-1.5 
tree. (Having learned my lesson about weird permissions, I did 
'pre-create' the C:\cygwin-1.7 directory and set the inheritable 
permissions on it the way I wanted em).

Now, I want to use setup-1.7 again to update the existing (1.7) 
installation.  Observing this:

> To update the 1.7 tree you will
> unfortunately have to run through the above

That is, stop all 1.5 processes, remove the 1.5 mount entries from the 
registry (using the umount command, not directly editing), and 
temporarily rename your 1.5 tree just to be paranoid.

> each time, as setup-1.7 will
> still see the 1.5 mount table in the registry, so you have to hide it
> first and restore the 1.5 one afterwards.

I ran setup-1.7 and carefully entered the correct path to my cygwin-1.7 
installation -- because setup found no registry info, it wanted to use 
the default C:\cygwin, and tried to put my local package directory 
inside C:\Windows\system32\...

Anyway, by the time I got to the chooser, setup-1.7 thought that I was 
doing a brand new installation. I had all the base files selected! 
That's not right.

It seems that, if setup-1.7 can't find mount information in the 
registry, it assumes you have a brand new installation and doesn't try 
to locate /etc/fstab and friends, much less /etc/setup/installed.db.

How can I use setup-1.7 to *update* -- not completely replace -- my 
side-by-side cygwin-1.7 installation?


More information about the Cygwin-apps mailing list