[ITP] graphviz/libgraphviz4/libgraphviz-devel/graphviz-doc/graphviz-contrib: An open source graph visualization software

Dr. Volker Zell dr.volker.zell@oracle.com
Mon May 5 17:12:00 GMT 2008

>>>>> Dave Korn writes:

    >   Well, the packaging looks ok, and the binaries appear to work after a bit of
    > crude smoke-testing, but I can't successfully rebuild from source.  I've tried
    > on two different systems now (both fairly up-to-date), and they've both hung
    > up at this stage:

    > -------------------------------------------------------------------------
    > Making all in vmalloc
    > make[3]: Entering directory
    > `/tmp/volker/graphviz/rebuild/graphviz-2.18-1/build/lib/vmalloc'
    > mkdir -p ../../FEATURE
    > /tmp/volker/graphviz/rebuild/graphviz-2.18-1/src/graphviz-2.18/iffe - set cc
    > gcc   : run
    > /tmp/volker/graphviz/rebuild/graphviz-2.18-1/src/graphviz-2.18/lib/vmalloc/fea
    > tures/vmalloc > ../../FEATURE/vmalloc
    > -------------------------------------------------------------------------

    >   In each case there was a stuck exe running, "FALBA2320.exe" for one and
    > FUBIK-something-or-other on the other.  The stuck exe was using zero cpu and
    > just sitting there indefinitely.  Running it manually at the command-line
    > didn't stall.  The sh.exe that invoked the iffe script is still alive but also
    > stalled.  After killing the exe, the shell wakes up and carries on with the
    > build.

    >   The FALBA2320.c test was checking for the presence of strdup and sure enough
    > it doesn't seem to appear in any of the feature test macros in
    > build/FEATURE/vmalloc.

Sorry, I'm busy at the moment I can only say it worked for me. I'll
check again if I can reproduce.


More information about the Cygwin-apps mailing list