Setup.exe issues between Win2k and WinXP - does it use different logic for setup retrieval or package ver selection

Brian Keener
Tue Jan 20 20:08:00 GMT 2009

I have noticed a different in my 2 machines I keep Cygwin on.  If I use 
a self compiled version (same compile) on each machine I get different 
results as to the Package version selection - for now I will leave this 
out of the discussion.  Trying to determine what this might be - I went 
and ran the setup.exe on each machine directly from the site 
(  One machine is a laptop and WinXP and the other is a 
desktop Win2k.  They each use the same mirrors and the last-mirror file 
on each shows:

the prc-tools is for my Palm code but both last-mirrors have the same 
mirrors in the same order.

Yet when I ran setup.exe from the web the WinXP machine advised:

unable to get 
from <>

which really doesn't surprise me as there probably is a setup.ini.sig.  
But on the Win2k machine I got:

Mirror Error: Setup.ini signature file from failed to verify. 
Possible corrupt mirror?  Setup.ini rejected.

And then when I click ok it gives me the same message about the 
setup.ini.sig from prc-tools - again understandable.  But why does the 
XP machine not have an issue with the gatech mirror but the Win2k 
machine does and it happens each time not just once.  When I click OK 
on the message about the prc-tools message for setup.ini.sig I then get 
the message about the corrupt mirror but this time for the site.  But when you click ok it then 
continues to download the setup.ini and parse it.

This brings us back to the original message about the difference in 
selected packages - the WinXP machine says I need to update libapr1, 
util-linux, xinit, and xterm and in this case the Win2k machine says no 
updates are needed but the two machines are at the
same version of each of these packages.

If I then look at the downloaded setup.ini files on each machine in the 
download directory the files match what setup showed for that machine - 
IE the setup.ini file for the same mirror for the 2 different machines 
is different even though I ran the setup.ini simultaneously so I could 
see what happened that was different.

Any thoughts - are there supposed to be 2 versions based on if it is 
Win2k vs WinXP


More information about the Cygwin-apps mailing list