setup.exe CoCreateInstance error.

Corinna Vinschen
Wed Jul 1 12:05:00 GMT 2009

On Jul  1 12:58, Dave Korn wrote:
> Corinna Vinschen wrote:
> > Can you add debug code which checks the return code of the
> > CoInitializeEx call in line 164?  Maybe that's already going
> > wrong.
>   Unfortunately no.  Happy return code zero.  I'm a security dork, so I
> wondered if maybe something I've disabled was breaking it, so I fired up the
> (normally disabled) DTC service, verified that DCOM was enabled using
> dcomcnfg, and took a browse around in the component services MSC to make sure
> it looked like it was working, but still no joy.

Grr.  I'd be glad if I could reproduce it because it would be nice,
for once, to have a Windows problem which at least pretends to be

> >  However, I don't know what to do besides of calling the
> > functions in different places depending on the OS.  That really doesn't
> > make sense.  I wish Microsoft had implemented a simple C function to
> > create shortcuts, rather than providing only this COM nonsense.
> > 
> > Oh well, given that W7 is not yet RTMed, maybe the problem still goes
> > away and the patch can be reverted.
>   Would be good if it happens.  You gonna file a report with them?  (For all
> the good that does :-/)

I tried, but failed.  I spent an hour or two to create a simple
testcase, but I didn't succeed.  Which is to say, whatever I tried,
it worked fine.  Only within setup I could reproduce this problem.
That doesn't exactly cast a positive light on setup.  Let's me wonder
if the actual problem is some mandelbug in setup itself...


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

More information about the Cygwin-apps mailing list