setup: CVS HEAD does not install test: releases

Andy Koppe
Mon Aug 16 05:59:00 GMT 2010

On 16 August 2010 06:32, Dave Korn wrote:
> On 16/08/2010 05:40, Andy Koppe wrote:
>> On 16 August 2010 04:25, Yaakov (Cygwin/X) wrote:
>>> setup CVS HEAD (2.717) does not download test: releases in either
>>> Install from Internet and Download Without Installing modes.
>>> I found this out by trying to install gcc4-*-4.5.0-1; after selecting
>>> the 4.5.0-1 versions of gcc4-*, they did not show up in the Pending
>>> view, nor were they downloaded or installed.  However, setup did
>>> uninstall my 4.3.4-3, leaving me without *any* gcc. :-(
>> You need to manually tick the 'Bin?' box when selecting the
>> experimental version. It's a longer-standing issue:
>> Another annoyance in this area is that once you do have an
>> experimental package installed, setup.exe always tries to downgrade
>> you back to the current one.
>  Another problem is that the dependencies don't work: if you select the test
> versions of a bunch of the language compilers, they don't cause the test
> versions of the related runtime libs to get automatically selected.

I downgraded back to 2.701 to see whether that worked with instant
dependency selection: it didn't. Phew, not a regression.

I guess the quick way to a consistent gcc-4.5 install is to just click
the 'Exp' button, although of course that drags in any other
experimental packages too.

>  On the other hand, setup is no longer trying to automatically downgrade the
> test packages any more.

It still does that for me, but once all experimental packages are
installed anyway, the 'Exp' button is an easy workaround.

>  But on the down side, it won't let me manually
> downgrade them either.  I had to uninstall all the 4.5.0 version packages in
> one step and then reinstall 4.3.4 in a second run through setup.exe.

I can't reproduce that. I tried upgrading to g++-4.5 and back to 4.3.4
and it worked.


More information about the Cygwin-apps mailing list