[ITA] Git et al

Adam Dinwoodie adam@dinwoodie.org
Sat Jul 19 07:29:00 GMT 2014

On Tue, Jun 10, 2014 at 11:20:41PM -0500, Yaakov Selkowitz wrote:
> On 2014-06-10 17:36, Adam Dinwoodie wrote:
> >The only outstanding issue with my build is that git-cvs wasn't working.
> >That seemed to be down to my build environment, as my attempts to build
> >the source code available via the Cygwin mirrors showed the same
> >behaviour, but those binaries work as expected.
> Are you only testing this with the Cygwin CVS repo?  Have you tried
> this with any other repos?  For example:
> :pserver:anoncvs@cygwin.com:/cvs/cygwin-apps setup (Cygwin setup)
> :pserver:anoncvs@cygwin.com:/cvs/cygwin htdocs (Cygwin website)

I've just dusted off this job, and although I was still unable to get
Git v1.8.5.2 working, bumping up to the latest v2.0.2 has had
considerably more success.

There are a few things to iron out yet: I've only checked the 32-bit
build so far, and I'm using a borrowed computer at the moment so I need
to make sure I can recreate the results on my machine.  I've also only
done very mainline testing thus far on this build, although the test
suite is running as I write this email.

I've still not been able to clone the Cygwin source code from CVS --
I've been testing by cloning the cygwin-apps repo Yaakov referenced
above -- but the errors look like a version incompatibility, and I don't
think there's much I can do about that.  If someone who knows more about
CVS and Git could take a look at the output and confirm that hypothesis,
I'd be grateful:

    $ git cvsimport -v -d :pserver:anoncvs@cygwin.com:/cvs/src src
    Initialized empty Git repository in /home/add/test/.git/
    Running cvsps...
    WARNING: malformed CVS version str: Server:
    WARNING: Your CVS client version:
    [Client: Concurrent Versions System (CVS) 1.12.13 (client/server)]
    and/or server version:
    [Server: ]
    are too old to properly support the rlog command.
    This command was introduced in 1.11.1.  Cvsps
    will use log instead, but PatchSet numbering
    may become unstable due to pruned empty

    cvs [log aborted]: reading from server: Connection reset by peer
    DONE; creating master branch
    fatal: refs/heads/origin: not a valid SHA1
    fatal: master: not a valid SHA1
    fatal: You are on a branch yet to be born
    checkout failed: 32768

As I say, the cvsimport of the cygwin-apps repo is going just fine, so I
don't think this is a fundamental problem with my build any more.
Fingers crossed for an up-to-date Git release soon.

More information about the Cygwin-apps mailing list