network installation failed, new diagnostics

Corinna Vinschen
Mon Jan 16 13:00:00 GMT 2017

On Jan 15 23:49, Thomas Wolff wrote:
> Concerning,
> I have some new insights; first, I tried with a range of older versions of
> setup.exe (from the cygwin time machine) but all failed, so its not a
> regression as I had speculated.
> Then I tried to run setup.exe without elevation, by elevating before
> (running mintty as adminstrator). So I noted (and could have checked this
> earlier...) that the involved network mounts were not fully established:
> mount (unelevated):
> L:/TGI/cygwin7 on / type ntfs (binary,auto)
> L: on /cygdrive/l type ntfs (binary,posix=0,user,noumount,auto)
> ...
> mount (elevated):
> // on / type ntfs (binary,auto)
> ...
> After fixing the mount:
> net use L: '\\\Labormaterial'
> setup.exe works as expected.
> Not being familiar with details of Windows permission stuff and
> user-specific mounts myself, does this help to analyse and maybe even fix
> the situation?

This is an UAC issue, not a Cygwin setup issue.  When elevating, the
mounts are not propagated to the elevated processes.  There's a
documented registry value enabling the supposedly dangerous propagation
of mount point to elevated processes, but I don't knowe it off the top
of my head.  You may want to search MSDN.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <>

More information about the Cygwin-apps mailing list