network installation failed, new diagnostics

Thomas Wolff
Sat Jan 21 19:28:00 GMT 2017

Am 16.01.2017 um 14:00 schrieb Corinna Vinschen:
> On Jan 15 23:49, Thomas Wolff wrote:
>> Concerning,
>> I have some new insights; first, I tried with a range of older versions of
>> setup.exe (from the cygwin time machine) but all failed, so its not a
>> regression as I had speculated.
>> Then I tried to run setup.exe without elevation, by elevating before
>> (running mintty as adminstrator). So I noted (and could have checked this
>> earlier...) that the involved network mounts were not fully established:
>> mount (unelevated):
>> L:/TGI/cygwin7 on / type ntfs (binary,auto)
>> L: on /cygdrive/l type ntfs (binary,posix=0,user,noumount,auto)
>> ...
>> mount (elevated):
>> // on / type ntfs (binary,auto)
>> ...
>> After fixing the mount:
>> net use L: '\\\Labormaterial'
>> setup.exe works as expected.
>> Not being familiar with details of Windows permission stuff and
>> user-specific mounts myself, does this help to analyse and maybe even fix
>> the situation?
> This is an UAC issue, not a Cygwin setup issue.  When elevating, the
> mounts are not propagated to the elevated processes.  There's a
> documented registry value enabling the supposedly dangerous propagation
> of mount point to elevated processes, but I don't knowe it off the top
> of my head.  You may want to search MSDN.
On my home systems, mounts are not propagated at all, I wouldn't expect 
setup to work then, agreed.
However, on that lab systems, the mounts are kind of half-way propagated 
to elevated mode.
They and visible and accessible using the network path (cd 
//; ...).
Now setup.exe apparently has remembered the network path for the Local 
Package Directory which appears as \\141... in the respective setup.exe 
screen, and in fact it does all the downloading to that directory, it 
just fails during later installation which corresponds to the Root 
Directory path appearing in drive format (L:...) in the respective 
setup.exe screen.
I'm just thinking if setup.exe would handle the Root Directory path in 
the same way as it handles the Local Package Directory path, the setup 
should work in that case.

More information about the Cygwin-apps mailing list