zsh 5.8: configure fails only on 32bit

Peter A. Castro doctor@fruitbat.org
Fri Jun 26 22:56:23 GMT 2020

On Thu, Jun 25, 2020 at 02:09:06PM -0700, Peter A. Castro wrote:
> Greetings, Mark & Yasuhiro,

(please excuse the top-posting :)

Greetings, again, Mark & Yasuhiro,

  I wanted to followup with you two on this.  But first, I've pushed a
new zsh-5.8 release so that should be available in a day or so.  Let me
know if you see any issues with it.

  Now, as to your own attempts: I wanted to ask if you had first applied
the patch from the previous release (zsh-5.5.1-1.patch from the
zsh-5.5.1-1-src.tar.bz2) before you attempted to run configure?  That
might be a logical step give that that does contain port specific

  If so, then that is going to be the problem.  It has been a while
since I'd roll a new zsh, but I recall finding that that particular
patch was tainted.  At some point, changes to how automake/configure
worked created a cache directory and the source package creation step
added that to the patch by mistake.  Re-applying it before running
configure creates a reall mess!

  I had it in my notes to correct this, but right then, my life became
complicated and I didn't have time to persue it, and since it was just
the source patch, and I the maintainer, I figure it wouldn't case any
harm until I fixed it.  It's been two years now and I'm back to being
able to be more active in other areas, including zsh maintinership.  (I
have to roll a new x3270 too at some point too, but that will take more

  So, if your problem was NOT that, then, I'm afraid you would have to
investigate that yourself.  Or, instead, just pester me for a new
release.  :)

   Again, sorry for any trouble, but life often throws curveballs at
us all.

> > From: Yasuhiro KIMURA <yasu@utahime.org>
> > Date: Thu, 25 Jun 2020 08:28:12 +0900 (JST)
> > Subject: Re: zsh 5.8: configure fails only on 32bit
> > 
> > From: Mark Geisert <mark@maxrnd.com>
> > Subject: Re: zsh 5.8: configure fails only on 32bit
> > Date: Tue, 23 Jun 2020 19:38:42 -0700
> > 
> > > Not sure if your end result will be a patch to the Cygwin zsh package
> > > or an ITA of same.  In either case it seems like the Cygwin zsh
> > > maintainer (Peter A. Castro) ought to be brought into this
> > > conversation...
> > 
> > I want to ask him some questions, so I'm very happy if he joins this
> > conversation. However, as zsh package hasn't been updated for about
> > two years even though 8 new versions are released by upstream, I
> > wonder if he is still active as maintainer,
> Sorry, I've been a little MIA due to many other things taking up my
> life/time.
> As for updating zsh, I'll see about getting a new package rolled soon.
> The releases of zsh post 5.5-1 have had their issues so I didn't feel
> they were quite ready for Cygwin.  But 5.8 looks pretty good, so I'll
> roll that up.
> As to why you are having problems running configure on 32-bit, I can't
> say as I don't use cygport to build it.  Also, I keep a somewhat older
> version of Cygwin for building purposes so that zsh will run with older
> versions too.
> So, if all you desire is a newer release, give me a day or two and I'll
> have get that uploaded.
> > ---
> > Yasuhiro KIMURA

--=> Peter A. Castro
Email: doctor at fruitbat dot org / Peter dot Castro at oracle dot com
	"Cats are just autistic Dogs" -- Dr. Tony Attwood

More information about the Cygwin-apps mailing list