ssh untest wget untest: unable to extract package and version from 'wget'

Brian Inglis
Mon Feb 28 17:56:53 GMT 2022

On 2022-02-28 04:07, Jon Turney wrote:
> On 28/02/2022 05:43, Brian Inglis wrote:
>> I had problems getting clean tests of upgraded wget locally for some 
>> reason, but the build and test worked well on scallywag.
>> So I set SCALLYWAG=deploy, pushed to master, and that worked properly, 
>> with calm upload email, and upgraded wget in x86{,_64}/setup.ini the 
>> only release under [test].
>> But I cannot run 'untest wget': what have I forgotten, or am I 
>> missing, to be able to run this?
>>      $ ssh untest wget
>>      untest: unable to extract package and version from 'wget'
>>      $ ssh 'untest --help'
>>      usage: [-h] [PACKAGE [PACKAGE ...]]
>>      test hint remover
>>      positional arguments:
>>        PACKAGE
>>      optional arguments:
>>        -h, --help  show this help message and exit

> You must include the version-release you wish to untest as well.
> e.g 'untest wget-1.21.3-1'
> See

Thanks for that example and link: noted for future ref; worked great!

> I'll fix the help text to reflect that.

That would be appreciated, and also maybe if you could please clarify 
the current error message text, I might have clued in (or not!) e.g.

"unable to extract package, version, release from 'wget' argument"

[Weird: ssh user@host changed to Gmane mailto link]

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

This email may be disturbing to some readers as it contains
too much technical detail. Reader discretion is advised.
[Data in binary units and prefixes, physical quantities in SI.]

More information about the Cygwin-apps mailing list