Heads up: Problems with parallel make

Ken Brown kbrown@cornell.edu
Tue Feb 14 00:38:05 GMT 2023

On 2/13/2023 6:44 PM, Brian Inglis wrote:
> On 2023-02-13 16:05, Ken Brown via Cygwin-apps wrote:
>> Several of my packages that used to build fine with parallel make now 
>> require 'make -j1'.  Without this I either get strange errors or a hang.
>> I can't find any pattern to explain when the problem occurs and when 
>> it doesn't, but it seems to be due to a change in make, starting with 
>> version 4.4.  By default, make now uses a FIFO rather than a pipe in 
>> its jobserver implementation.  You can override this with the make flag
>>    --jobserver-style=pipe
>> In all cases where I've tried this, parallel make works again.
>> It wouldn't surprise me if there's a bug in Cygwin's FIFO 
>> implementation that's responsible for this, but I haven't yet tried to 
>> track it down.
> There is some glibc? compatibility issue also with this recommended 
> workaround.

Could you elaborate?  I don't know what issue you're seeing.


More information about the Cygwin-apps mailing list