Heads up: Problems with parallel make

Marco Atzeri marco.atzeri@gmail.com
Tue Feb 14 21:23:46 GMT 2023


On 14.02.2023 17:49, Brian Inglis via Cygwin-apps wrote:
> On 2023-02-13 17:38, Ken Brown via Cygwin-apps wrote:
>> On 2/13/2023 6:44 PM, Brian Inglis wrote:
>>> On 2023-02-13 16:05, Ken Brown via Cygwin-apps wrote:
>>>> Several of my packages that used to build fine with parallel make 
>>>> now require 'make -j1'.  Without this I either get strange errors or 
>>>> a hang.
>>>> I can't find any pattern to explain when the problem occurs and when 
>>>> it doesn't, but it seems to be due to a change in make, starting 
>>>> with version 4.4.  By default, make now uses a FIFO rather than a 
>>>> pipe in its jobserver implementation.  You can override this with 
>>>> the make flag
>>>>    --jobserver-style=pipe
>>>> In all cases where I've tried this, parallel make works again.
>>>> It wouldn't surprise me if there's a bug in Cygwin's FIFO 
>>>> implementation that's responsible for this, but I haven't yet tried 
>>>> to track it down.
>>>
>>> There is some glibc? compatibility issue also with this recommended 
>>> workaround.
>>
>> Could you elaborate?  I don't know what issue you're seeing.
> 
> There have been reports from various projects mentioning problems in 
> other packages ending up at make 4.4 and FIFOs solved by reverting to 
> pipes.
> 
> There is a make 4.4.1 release candidate 4.40.0.90 with patches that may 
> help to deal with this:
> 
>      https://alpha.gnu.org/gnu/make/make-4.4.0.90.tar.lz{,.sig}
> 
> https://sv.gnu.org/bugs/index.php?group=make&report_id=111&fix_release_id=110&set=custom
> 

test version built and on the way

please check




More information about the Cygwin-apps mailing list