[PATCH cygport] Add customization support for announce command

Jon Turney jon.turney@dronecode.org.uk
Sun Mar 10 14:37:59 GMT 2024


On 23/02/2024 11:23, Christian Franke via Cygwin-apps wrote:
> Christian Franke wrote:
>> The email generated by the cygport announce command is useful, but 
>> actual use cases are somewhat limited due to the hard-coded email 
>> submission.
>>
>> The attached patch adds more flexibility. The patch is on top of the 
>> "Use correct wording if only one package is announced" patch.
> 
> Slightly changed patch attached. Also adjusted to new version of "Use 
> correct wording if only one package is announced" patch.
> 
> 
[...]

Thanks for this.

> Possible (better?) alternative names for the new settings:
> ANNOUNCEMENT_EDITOR
> ANNOUNCEMENT_MAILER

Hmmm... I think "ANNOUNCE_EDITOR" and "ANNOUNCE_MAILER" would be
the best for clarity and conciseness.

> -From: ${SMTP_SENDER}
> -To: cygwin-announce@cygwin.com
> +${SMTP_SENDER:+From: ${SMTP_SENDER}
> +}To: cygwin-announce@cygwin.com
>  Date: $(date -R --date=${msgat})
> -Message-Id: <$(date "+%Y%m%d%H%M%S.$$" --date=${msgat})-1-$(echo ${SMTP_SENDER} | sed 's|.*<\(.*\)>.*|\1|')>
> +Message-Id: <$(date "+%Y%m%d%H%M%S.$$" --date=${msgat})-1-$(echo ${SMTP_SENDER:-cygport} | sed 's|.*<\(.*\)>.*|\1|')>
>  Subject: ${NAME} ${PVR}

Can you also explain what this is doing in the commit message, since 
it's not immediately apparent.



More information about the Cygwin-apps mailing list