Testing/Feedback on new setup.exe

Chris Faylor cgf@cygnus.com
Wed Apr 12 07:55:00 GMT 2000

On Tue, Apr 11, 2000 at 11:27:09PM -0700, Mo DeJong wrote:
>If tar exits with some error condition, the installer needs to stop and
>give the user some indication of the package that generate the errors
>and what they should do next.  We could print something like this:

If I understand things correctly, the install.log file is not
intended to catch errors.  It just grabs output from tar so
that an uninstall script can be created.

>"Error installing the gdb-20000127.tar.gz
>package. You may have a corrupted tar file,
>or there may be some other problem with your
>install. Check the README and the FAQ
> http://sourceware.cygnus.com/cygwin/faq "

Care to submit a patch?

>% tar -C / -xzvf gdb-20000127.tar.gz
>/usr/bin/tar.exe: usr/lib/libtcl80.a: Could not create file: Permission 
>/usr/bin/tar.exe: usr/lib/libtk80.a: Could not create file: Permission
>/usr/bin/tar.exe: usr/man/man1/itclsh.1: Could not create file: Permission
>/usr/bin/tar.exe: usr/man/man1/itkwish.1: Could not create file:
>Permission denied
>/usr/bin/tar.exe: usr/man/man3/Resolvers.3: Could not create file:
>Permission denied

Corinna had already noted these errors and is tracking down the cause.
I hope.

>Something really strange is going on in /usr/lib.  If I do a "ls
>/usr/lib" I can see the files that were installed but if I open the
>same directory in explorer it does not see the files, the dir just
>appears empty.  I did not see this error with the last installer and it
>should be the only thing that is different.  Was something in the
>installer changed that would explain this error?

/usr/lib is a "symbolic link" to /lib.  See previous voluminous
discussions about this in the cygwin-developers mailing list.

>I thought I would try to work around the
>problem by just removing the directory
>that contained the gdb tar.gz file.
>That worked in the sense that the installer
>would install without errors, but
>I would like to be able to run
>gdb so it is not a very good fix.

How about installing from the Internet?  It sounds like your gdb.tar.gz
file might have been corrupted.

>I also tried putting the setup.exe file into the "root" dir of the
>files I downloaded off the ftp site.  I downloaded to
>C:\Temp\cygwin-net-485, so the bash tar file was
>C:\Temp\cygwin-net-485\bash\bash.tar.gz.  I saved the installer to
>C:\Temp\cygwin-net-485\setup.exe and tried to run it, it puked out
>these errors.
>Press <enter> to accept the default value.
>Root directory? [C:\Cygwin]
>Install from the current directory (d) or from the Internet (i)? [i] d
>Installing ash.tar.gz
>Unable to extract "ash.tar.gz": No error
>Installing bash.tar.gz
>Unable to extract "bash.tar.gz": No error
>This seems like an error that a user is likely to make, so we really
>should put a note about this in the README.

Or, patch the installer to do the right thing.  Care to take a stab at
this?  I don't know why extracting things here would present a problem,

>As a side note, it would be VERY helpful if error messages were
>actually captured and written to install.log.  The errors can be echoed
>to the console in addition to being written to the log, but not writing
>them to the log is just a bad idea.  We need to be able to tell users
>"just send us the log" to figure out where the problems are.

Since the install.log file is used for something else, I'm not sure that
that's a good idea.  I'll look at the source code and see if errors can
be filtered out while the log file is being processed.

>I also took a look at the README file,
>it details how to bootstrap a cygwin install
>in the event you do not have an installer.
>This file needs to be updated to account for
>the new install process. If nobody else
>pipes up saying they want to do it,
>I can write the new README.


>This is a minor issue, but should the name of startup.zip be changed to
>bootstrap.zip?  That might help clear up what the file is actually used
>for.  That of course assumes that we even want to keep it around now
>that we have an installer.

I don't know.  "bootstrap" may not be as clear to a non-technical user.
I am open to a vote on the subject, though.


More information about the Cygwin-developers mailing list