mount doesn't complain about missing "mount directory" any more?

Chris Faylor
Thu Jun 15 09:34:00 GMT 2000

On Thu, Jun 15, 2000 at 10:26:48PM +0900, Kazuhiro Fujieda wrote:
>>>> On Wed, 14 Jun 2000 01:03:12 -0400
>>>> Chris Faylor <> said:
>> I think you may have misunderstood me.  I wanted to be able to
>> type "umount c:\foo" (I got the backslash wrong above) and have
>> it remove the mount point.  This is what it does on UNIX.
>I'm sorry. I didn't know the umount can accept a device name on
>UNIX. I tried implementing this behavior in umount of Cygwin.
>In my implementation, the umount invoked with a native path (or
>something like it) deletes all mount entries having the same
>native path. Because the mount in Cygwin unlike one in UNIX can
>mount the same source path on more than two different mount

Actually, UNIX can mount two devices, too.  I just tried it, and a umount
removes the first in the mount list.  Is it possible to adapt your patch
to do that?


>By the way, I found the mount didn't eliminate a trailing
>backslash in a native path starting with `//[A-Za-z]/'.
>The following patch also fixes this problem.
>2000-06-15 Kazuhiro Fujieda  <>
>	* (mount_info::add_item): Eliminate a trailing backslash 
>	included in a native path starting with '//[A-Za-z]/...'.
>	* (mount_info::del_item): Accept a native path as its target.

More information about the Cygwin-developers mailing list