Problems with texi2html, docbook-tools, and building Cygwin Doc???

Brian Keener bkeener@thesoftwaresource.com
Sun Nov 19 13:13:00 GMT 2000


When I build cygwin from the cvs updates I always get the errors at the 
end of the build regarding db2html and texi2html.  So I decided to do 
something about it and try to get them installed - just to learn and do 
away with the errors.

I am curious before I start this - when was the last time someone tried 
to build texi2html and docbook-tools and the cygwin documentation from 
scratch - does it still work??  It is probably just something in my 
configuration (and my inexperience) but this did seem extremely more 
difficult and troublesome than some of the other things I have tried.

Following the FAQ instructions I went to the appropriate cvs servers for 
texi2html and docbook-tools and did a cvs checkout on them. I also 
downloaded a perl-5 binary package from its appropriate location.  I got 
the perl installed no sweat and then moved on to texi2html.

I did my configure and then went to do the make.  Right off the bat the 
make complains about @command, @acronym, an out of place @end ifnottex 
and several other items as well as out of place braces which were 
obviously related to the above bad commands.  Of course next time you do 
a make you don't get these errors because make thinks it has already done 
it and finishes the make.  Now if you do a make install on texi2html then 
it makes the appropriate directories and tries to run the install 
executable from vim (which doesn't seem to do what it is supposed to) and 
fails.  Once I figured this out I used the install from /usr/bin and got 
the texi2html files installed in /usr/local where they go by default.  I 
accomplished this through the command line and not actually modifying any 
scripts.

Next I did a make on my cygwin build and it's make files for the 
documentation don't seem to be correct.  I had to change an option for 
texi2html -Isrcdir to texi2html -I=srcdir and also there was another 
reference to -split-chapter which should be -split=chapter.  I have my 
changes on this and I assume I could provide a diff for the maintainer if 
needed.  I finally got it to the point where it wanted to run and then 
complained that the file sites.texinfo was missing.

I also attempted to get the docbook-tools installed, but could only find 
installation instructions for building as an rpm and putting on the web 
(not sure why this would be here??).  I looked in several subdirectories 
and really found nothing referring to configure or makefiles.

I am interested in any additional information and or suggestions anyone 
can provide and also has anyone else run into these same problems and how 
were they resolved.  I'll even accept give it up ;-).





More information about the Cygwin-developers mailing list