Does CVS build?

Charles Wilson cwilson@ece.gatech.edu
Wed Aug 15 15:08:00 GMT 2001


Earnie Boyd wrote:

> Charles Wilson wrote:
> 
>>Which autoconf were you using to regenerate configure?
>>
>>
> 
> I used 2.13.  


Good.  If I can come up with some compatibility patches that make it 
"work" for 2.52, then at least there's *somebody* around who can make 
sure I don't break things for 2.13.

> I know better than to get rid of a good thing just yet. 
> There are so many changes happening with autotools that updating
> versions just has to be a HOALOW.  Just keeping the correct versions of
> sister tools is enough to throw you into a nightmare.


Yes, but...the autoconf people no longer support 2.13.  In fact, the 
situation is remarkable similar to B20.1 vs. 1.x.x:

Q) but X worked on 2.13
A) 2.52 provides many additional features and is the future path.
Q) but there's so much stuff that's incompatible with the new version
A) Not if this "stuff" followed the rules originally.  Most of the 
problems are cause when people redefine internal macros (like 
AC_PROG_CC_WORKS) in external projects.  Of course we reserve the right 
to modify internal architecture.  Other than those problems, there are 
very few incompatibilities -- and we even provide a tool to do the 
migration for those (autoupdate).  Unfortunately, autoupdate can't fix 
problems that arise when packages break the rules (.._WORKS & friends)

--Chuck




More information about the Cygwin-developers mailing list