Updated setup.ini with descriptions, categories, and dependencies

Corinna Vinschen vinschen@redhat.com
Tue Aug 28 06:06:00 GMT 2001


On Tue, Aug 28, 2001 at 04:37:02PM +0400, egor duda wrote:
> Hi!
> 
> Tuesday, 28 August, 2001 Corinna Vinschen vinschen@redhat.com wrote:
> 
> CV> On Tue, Aug 28, 2001 at 04:06:49PM +0400, egor duda wrote:
> >> Tuesday, 28 August, 2001 Corinna Vinschen vinschen@redhat.com wrote:
> >> >> @ automake
> >> >> sdesc: "A GNU tool for automatically creating Makefiles"
> >> 
> >> CV> sdesc: "A tool for automatically generating GNU style Makefile.in's"
> >> 
> >> >> category: Development/Tools
> >> >> requires: ash perl
> >> 
> >> CV> requires: ash cygwin perl
> >> 
> >> why? automake doesn't contain any binaries. it's even made as "noarch"
> >> rpm in linux distros, iirc. i suppose we shouldn't include "recursive
> >> dependencies" into the list, should we?
> 
> CV> What exactly is `recursive' in the above list of required packages?
> 
> by "recursive" i mean "dependencies for dependencies". cygwin _is_
> required to run perl and ash, but automake itself is
> "architecture-independent" package and will run on any platform, as
> long as perl and /bin/sh are installed and can be run.

Hmm, yes, sure. I don't have a strong opinion here so

requires: ash perl

is ok with me, too.

Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin@cygwin.com
Red Hat, Inc.



More information about the Cygwin-developers mailing list