Problems with autoconf-2.52 testsuite using current CVS Cygwin

Robert Collins robert.collins@itdomain.com.au
Mon Jul 30 02:10:00 GMT 2001


On 30 Jul 2001 10:15:14 +0200, Corinna Vinschen wrote:
> On Mon, Jul 30, 2001 at 01:49:27AM -0400, Charles Wilson wrote:
> > Charles Wilson wrote:
> > 
> > 
> > > 
> > > Changes by:    corinna@sources.redhat.com    2001-07-09 02:02:42
> > > Modified files:
> > >     winsup/cygwin  : ChangeLog security.cc
> > > Log message:
> > >     * security.cc (alloc_sd): Don't set inheritance attribute for
> > >     permissions given to directories.
> > > 
> > 
> > Well, this is definitely the culprit; this change plus W2K/NTFS.  I 
> 
> I still doubt that that is the problem for two reasons.
> 
> First, I can't reproduce the below behaviour in a NTFS dir (which
> isn't that evident, though). The directories have permissions
> 700 as the testsuite creates them, the subordered files have
> 644 permissions. Both shouldn't result in a problem to delete
> the files.
> 
> And second, as I already mentioned, the autoconf-2.52 testsuite
> fails even in a /tmp on _FAT_ which is definitely not ntsec related.
> 
> > don't get the problematic behavior on NT/NTFS.  However, I know that 
> > Corinna put this in for a reason -- but I don't remember what it was. :-(

Two thoughts:
The main problem was the ash vfork issue meaning that the exit code
wasn't running causing directory name collisions.
Chuck has found a separate issue, related to the NTFS problem...

Rob



More information about the Cygwin-developers mailing list