Positive and negative results with cygserver.exe

Gary R. Van Sickle g.r.vansickle@worldnet.att.net
Sat Jan 12 15:30:00 GMT 2002

This is all on WinXP.

Got it built, manually copied the following to /bin (note that install will
choke looking for "install-bin" when trying to install w32api stuff to a
"staging" install directory):

  cygrun.exe (not sure if this was part of it, haven't seen it before, now that
I look at the code it looks like it isn't)

Running cygserver from an rxvt/bash prompt works, cygserver sits and looks like
it's waiting for "connections" or whatever.  However, it blocks a new rxvt/bash
prompt from coming up (looks like rxvt itself is blocked halfway through drawing
the screen, eg. scrollbar looks like it started to get drawn).  I'm using this
in the shortcut:

C:\unix\bin\rxvt.exe -tn rxvt -sr -sl 1000 -fn "Lucida Console-bold-14" -e
bash --login -i

Killing cygserver via task manager (or CTRL-C) unblocks rxvt.  "bash --login -i"
will however start up in a cmd.exe window and appears to work fine.  Running
cygserver from a cmd prompt (no other shell or other cygwin prog. involved)
makes no difference in the rxvt-blocking behavior.

Running cygserver in a straight cmd window and "bash --login -i" in another, I
reran the build of the cygwin tree.  Everything worked the same as it did with
1.3.6-6 (i.e. successfully except for the install-bin issue, which I assume is a
branches-out-of-sync issue).  Millions of "."s from cygserver, indicating that
it was in fact getting hit.

Also ran without cygserver running but with the new cygwin1.dll.  Everything
worked again.  Noticed no speed difference:

With cygserver running:
real    40m2.384s
user    17m20.654s
sys     12m26.704s

real    42m31.088s
user    17m17.047s
sys     12m13.288s

These times are comparable to what I was seeing with 1.3.6-6.

Gary R. Van Sickle
Brewer.  Patriot.

More information about the Cygwin-developers mailing list