AUGHT I just "upgraded" to the latest gcc.gnu.org gcc

Parker, Ron rdparker@butlermfg.com
Fri Jan 18 04:49:00 GMT 2002


> -----Original Message-----
> From: Christopher Faylor [mailto:cgf@redhat.com]
> Sent: Wednesday, January 16, 2002 9:16 PM
> To: cygwin-developers@cygwin.com
> Subject: AGGHHH I just "upgraded" to the latest gcc.gnu.org gcc
> 
> 
> I just upgraded my linux cross compiler to the latest version from
> gcc.gnu.org.  The compiler built without a hitch.  I rebuilt 
> cygwin and
> now it loops in an exception (as far as I can tell).

I can say that the cygwin native 3.0.3 compiler works for a lot of what I
have tried, but I have not tried rebuilding cygwin itself as yet. And while
I haven't tried it yet with a linux->cygwin cross.  I was trying to build a
cygwin->linux cross of gcc 3.0.3 without bringing over my glibc from my
linux box.  Yes I'm a masochist.  My ultimate goal was to do some much
needed compiling with spare cycles while doing "real work" *cough* *cough*
in Windows.  

> So, I decide to rebuild absolutely everything.  Newlib flies by but I
> can't rebuild libstdc++-v3.  It absolutely refuses to build.  Problems
> in libtool.
> 
> So, I try to update my libtool via RPM.  It has many 
> dependencies.  And,
> some programs depend on the packages that libtool uses so I have to
> update them.  That eventually means I have to update my libc.
> 
> I finally get libtool updated.  Same problem in libstdc++-v3.  I fix a
> bug in the configure script and that gets me a little further.  Lots
> of multiply defined errors, though.  In desperation, I try "make -k".
> No dice.  Apparently configuration for libstdc++-v3 is confused wrt
> newlib or something.

Exact same results here. I agree that libstdc++-v3 is VERY confused wrt
newlib.  It doesn't appear that Cygwin+newlib+gcc-3.0.3 is a good
combination.  Even building gcc cygwin->linux with the --with-newlib
configuration argument seems to seriously choke.  It still goes off looking
for glibc headers.  I decided that 3.0.3 needed to ripen some more.



More information about the Cygwin-developers mailing list