Chris January chris@atomice.net
Fri Jul 5 15:39:00 GMT 2002

> > > CJ> Will this package actually appear on the mirrors in future or are
> > there
> > > CJ> issues I am not aware of preventing this from happening?
> > >
> > > Have you tried running the procps tools on current stock dll
> > > (1.3.12-1) ? For me most of them seem to just hang - top, procps,
> > > uptime, vmstat, w... havent tried the others.
> > >
> > > Maybe this problem corelates with the fact that some of the /proc
> > > files no longer contain information - see below:
> > > Perhaps it has to do something with your last patch. I don't have time
> > > to look at this right now though. I can send strace if you want.
> > >
> > > The procps tools I'm using were downloaded from your site following
> > > their anouncement on cygwin-apps.
> > This is caused by the default alignment changing from 4 bytes to 8
> as
> > far as i can tell. Basically the size of structure passed to the NT
> > calls is not the size of structure the call expects, so it fails and the
> > program (top, uptime, etc.) gets stuck in a loop trying to read data.
> > I did add macros to ntdll.h to make sure the structures were aligned
> > correctly, but then Chris changed the alignment back so I removed them.
> > shall let Chris comment on this.
I would appreciate it if you could look into this Chris, since using my
build environment, I can compile the 1.3.12 sources and the Cygwin DLL works
fine. However with the binary in the 1.3.12-1 binary distribution, I am
seeing the failures others have experienced, namely with the
NtQuerySystemInformation call failing. Since I can't reproduce the problem
on my machine, I don't really know where to begin fixing it.
I am using binutils 20011002-1 and gcc version 2.95.3-5 (cygwin special).


More information about the Cygwin-developers mailing list