later w32api package required to build cygwin

Brian Keener bkeener@thesoftwaresource.com
Thu Nov 14 14:23:00 GMT 2002


Nicholas Wourms wrote:
> After investigating a few minutes, I found that in 
> Makefile.common changing:
> 
> w32api_include:=-I$(w32api_source)/include
>
Gosh I was hoping that would work but I tried it and I still get the same error 
on IOCTL_DISK_UPDATE_DRIVE_SIZE as follows

/usr/develop/src/winsup/cygwin/fhandler_floppy.cc: In member function `virtual
   int fhandler_dev_floppy::ioctl(unsigned int, void*)':
/usr/develop/src/winsup/cygwin/fhandler_floppy.cc:278: `
   IOCTL_DISK_UPDATE_DRIVE_SIZE' undeclared (first use this function)
/usr/develop/src/winsup/cygwin/fhandler_floppy.cc:278: (Each undeclared
   identifier is reported only once for each function it appears in.)
make[2]: *** [fhandler_floppy.o] Error 1
make[2]: Leaving directory `/usr/develop/obj/i686-pc-cygwin/winsup/cygwin'
make[1]: *** [cygwin] Error 1
make[1]: Leaving directory `/usr/develop/obj/i686-pc-cygwin/winsup'
make: *** [all-target-winsup] Error 2

Which leads me to believe I am still getting the wrong w32api.

bk




More information about the Cygwin-developers mailing list