Problem building with old include and libs for newer DLL?

Christopher Faylor cgf@redhat.com
Sat Jul 5 22:06:00 GMT 2003


On Sat, Jul 05, 2003 at 07:12:47PM +0200, Corinna Vinschen wrote:
>On Sat, Jul 05, 2003 at 09:59:26AM -0400, Christopher Faylor wrote:
>> On Sat, Jul 05, 2003 at 11:18:47AM +0200, Corinna Vinschen wrote:
>> >If headers and libcygwin.a match, then yes, it should work.  Headers and
>> >libcygwin.a depend on each other.
>> 
>> That's what I thought.  I wish I'd done a little more research before I
>> updated my installation.  Maybe I was out of sync wrt headers and libraries
>> but I don't know how I could have gotten that way.  Oh well.
>
>I had the same problem some weeks ago.  Using setup.exe to revert to
>1.3.22 Cygwin solved it for me.

This is on linux, though.  I don't know how I could have gotten in the state
where the libraries didn't match the headers but anything is possible.

cgf



More information about the Cygwin-developers mailing list