src/winsup/cygwin ChangeLog include/cygwin/in6 ...

Corinna Vinschen corinna-cygwin@cygwin.com
Wed Mar 12 09:32:00 GMT 2014


On Mar 11 22:25, Yaakov (Cygwin/X) wrote:
> On 2014-01-20 11:25, corinna wrote:
> >CVSROOT:	/cvs/src
> >Module name:	src
> >Changes by:	corinna	2014-01-20 17:25:54
> >
> >Modified files:
> >	winsup/cygwin  : ChangeLog
> >	winsup/cygwin/include/cygwin: in6.h socket.h
> >
> >Log message:
> >	* include/cygwin/in6.h (struct ipv6_rt_hdr): Define.
> >	* include/cygwin/socket.h: Fix formatting.
> >	(IP_UNICAST_IF): Define.
> >	(IPV6_JOIN_GROUP): Remove Windowism.
> >	(IPV6_LEAVE_GROUP): Ditto.
> 
> IPV6_{JOIN,LEAVE}_GROUP are not Windowsisms; they are the names in
> RFC 2553[1] and its replacement RFC 3493[2], and are defined in
> glibc, BSDs, and other UNIXs, while IPV6_{ADD,DROP}_MEMBERSHIP are
> from their obsolete predecessor, RFC 2133[3][4].

Oops.  I reverted the patch.  Sorry.
Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin-developers/attachments/20140312/cc96fed1/attachment.sig>


More information about the Cygwin-developers mailing list