cygwin build drops out

Mark Geisert
Wed Jun 30 20:10:14 GMT 2021

Thomas Wolff wrote:
> Am 30.06.2021 um 18:07 schrieb Ken Brown:
>> On 6/30/2021 10:39 AM, Thomas Wolff wrote:
>>> Hi, recently I cannot build cygwin anymore.
>>> With a fresh git checkout, configure and make builds the newlib tree, no 
>>> errors, but no winsup tree is built.
>>> Any similar problem or known current issue?
>> This might be because of the recent switch to automake.  You have to run 
>> winsup/
>> Ken
> It says
> parallel-tests: installing '../test-driver'
> and terminates after a few seconds.
> A new attempt to `make` changes nothing, still no winsup made.
> Thomas
I hit this too; forgot to raise the issue here.  What I ended up doing is putting 
the build directory within the root of the git tree.
I used to have:
     /oss/src -> /c/staging/newlib-cygwin == the git tree
but now have:
     /oss/build -> /c/staging/newlib-cygwin/build
     /oss/src -> /c/staging/newlib-cygwin

Then within that new build directory I run /oss/src/configure [blah] then make.


More information about the Cygwin-developers mailing list