thunk createDirectory and createFile calls
Fri Nov 14 18:51:00 GMT 2003
On Sat, Nov 15, 2003 at 04:48:16AM +1100, Robert Collins wrote:
> On Sat, 2003-11-15 at 02:52, Christopher Faylor wrote:
> > On Fri, Nov 14, 2003 at 08:41:21PM +1100, Robert Collins wrote:
> > > Rename CreateFile to cygwin_create_file throughout.
> > ^^^^^^^^^^^^^^^^^^
> > > Rename CreateDirectory to cygwin_create_directory throughout.
> > ^^^^^^^^^^^^^^^^^^^^^^^
> > It is a given that we're working in cygwin. Adding a cygwin_ to the
> > beginning of a function is just noise.
> Heh, will fix... was following Ron's convention semi-blindly.
Well, we have a small problem with get_file_attributes and
set_file_attributes. We already have two functions called
get_file_attribute and set_file_attribute. Note that the difference
is only the trailing 's'.
I'd suggest to change the name of the exisiting functions to something
a bit different so that it's less likely to confuse the two calls.
get_file_permissions and set_file_permissions would be good names for
them, wouldn't they?
Corinna Vinschen Please, send mails regarding Cygwin to
Cygwin Developer mailto:firstname.lastname@example.org
Red Hat, Inc.
More information about the Cygwin-patches