Fri May 13 06:52:00 GMT 2011
On May 12 15:30, Ryan Johnson wrote:
> On 12/05/2011 2:42 PM, Corinna Vinschen wrote:
> >On May 12 13:53, Ryan Johnson wrote:
> >>On 12/05/2011 12:55 PM, Corinna Vinschen wrote:
> >>>>> heap *heaps;
> >>>>This is a misnomer now -- it's really a list of heap regions/blocks.
> >>>I don't think so. The loop stores only the blocks which constitute
> >>>the original VirtualAlloc'ed memory regions. They are not the real
> >>>heap blocks returned by Heap32First/Heap32Next. These are filtered
> >>>out by checking for flags& 2 (**).
> >>Sorry, I cut too much context out of the diff. That's
> >>heap_info::heaps, which indeed refers to heap regions which we
> >>identified by checking flags&2 (that's why it needs the heap_id
> >>inside it now, where it didn't before) (++)
> >So you think something like heap_chunks is better?
> Maybe. I actually only noticed because the code snippet you
> originally sent also used 'heaps' as an identifier and the two
> clashed when I pasted it in ;)
I've renamed it to heap_vm_chunks and checked my patch in.
I'm going to follow up on the cygwin-developers list. Now that we have
your excellent maps output, it's pretty easy to see where the potential
problems for fork are.
Corinna Vinschen Please, send mails regarding Cygwin to
Cygwin Project Co-Leader cygwin AT cygwin DOT com
More information about the Cygwin-patches