[PATCH] Implement sigtimedwait

Mark Geisert mark@maxrnd.com
Fri Dec 15 01:09:00 GMT 2017


On Thu, 14 Dec 2017, Corinna Vinschen wrote:
> Hi Mark,
>
> Thanks for sigtimedwait!  Two questions:
>
> On Dec 13 22:54, Mark Geisert wrote:
>> diff --git a/winsup/cygwin/signal.cc b/winsup/cygwin/signal.cc
>> index 69c5e2aad..0599d8a3e 100644
>> --- a/winsup/cygwin/signal.cc
>> +++ b/winsup/cygwin/signal.cc
>> [...]
>> +	}
>> +      cwaittime.QuadPart = (LONGLONG) timeout->tv_sec * NSPERSEC
>> +                          + ((LONGLONG) timeout->tv_nsec + 99LL) / 100LL;
>> +    }
>> +
>> +  return sigwait_common (set, info, timeout ? &cwaittime : cw_infinite);
>
> Would you mind to change the name of cwaittime to waittime throughout?
> The leading "cw" actually puzzeled me for a while since I misinterpreted
> it as one of the cw_* constants.  No idea if it's just my bad eyes, but
> dropping the leading c might raise readability a bit.

I don't mind.  What I was attempting to communicate with "cwaittime" was a 
wait time in "cygwait units" of 100ns.  But I wasn't happy with it either.

Revised patch correcting both points is on its way.
Thanks much,

..mark



More information about the Cygwin-patches mailing list