[PATCH] Cygwin: pty: Fix segfault caused when tcflush() is called.

Thomas Wolff towo@towo.net
Tue Feb 23 17:15:12 GMT 2021

Am 23.02.2021 um 14:33 schrieb Takashi Yano via Cygwin-patches:
> On Tue, 23 Feb 2021 22:13:52 +0900
> Takashi Yano wrote:
>> Hi Thomas,
>> On Tue, 23 Feb 2021 12:24:09 +0100
>> Thomas Wolff wrote:
>>> I've downloaded yesterday's snapshot (2021-02-22) for some testing.
>>> If I compile mintty (which passes without problem) and try to run it, it
>>> just exits silently (no window popped up).
>>> After reverting to 3.1.7, it runs just fine (even the one compiled with
>>> the snapshot).
>> Thanks for testing. However, I cannot reproduce your problem.
>> I downloaded mintty-3.4.6-1-src.tar.xz and extract it.
>> Then run
>> cygport mintty-3.4.6-1.cygport prep
>> cygport mintty-3.4.6-1.cygport compile
>> The binary in build/bin directory works with cygwin snapshot
>> 2021-02-22. I have tried both 32bit and 64bit build, and both
>> work without problem.
>> Could you please provide some more information?
> Difference of compiler version?
> I am using gcc-g++ 10.2.0-1.
Apologies, I confused this. I *wanted* to try the snapshot but then 
tried a self-compiled dll instead (fresh git pull).
The snapshot works. The git pull doesn't but that may have other 
mysterious reasons.

More information about the Cygwin-patches mailing list