rebuilding for MIPS cross-compile

Scott Mintz
Fri Apr 4 13:11:00 GMT 1997

     I ran into this problem myself.  The cause is due to the fact that the 
     xgcc program is referencing the build ld program instead of the host 
     ld program.  configure creates a link to the correct ld program 
     however it names it collect-ld for some reason.  If you copy 
     collect-ld to ld you'll find the problem goes away.
     The other problem I ran into was while rebuilding newlib.  In the 
     libc/stdio directory, there are a number of references to glue.h.  
     Since glue.h doesn't exist in the stdio directory make fails.  I found 
     a copy in the libgloss directory and just copied it to stdio and that 
     problem went away too.
     The biggest problem by far, is the fact that exporting environment 
     variables doesn't seem to work correctly.
     bash$ foo=hello echo $foo
     I would expect to see:
     bash$ foo=hello echo $foo
     Because of this bug the genmultilib script in gcc does not create the 
     multilib.h file correctly.  I'm not sure how many other places this 
     bug affects builds.
     | Scott A. Mintz               | voice: (216) 646-4805              |
     | Allen-Bradley Company        | fax:   (216) 646-4961              |
     | 1 Allen-Bradley Drive        | email:   |
     | Mayfield Hts., OH 44124-6118 | CIS:   71461,632                   |


______________________________ Reply Separator _________________________________
Subject: rebuilding for MIPS cross-compile
Author:  "Russell Kadota" <> at Internet
Date:    4/3/97 5:04 PM

Hello --
I'm trying to rebuild from source, hosting on NT 4, with 
mips-idt-ecoff as the target.  The configure stage seemed to run 
without incident.  However, during the make it failed trying
to build libgcc1-test.  Here are the last few lines from the log 
 (Begin logfile excerpt):
/software/cygwin/src/gcc/xgcc -B/software/cygwin/src/gcc/ -DCROSS_COMPILE 
-DIN_GCC   -g -I./include     -c ./libgcc1-test.c
Testing libgcc1.  Ignore linker warning messages. 
/software/cygwin/src/gcc/xgcc -B/software/cygwin/src/gcc/ -DCROSS_COMPILE 
-DIN_GCC   -g -I./include  libgcc1-test.o -o libgcc1-test \
  -nostartfiles -nostdlib `/software/cygwin/src/gcc/xgcc
-B/software/cygwin/src/gcc/ --print-libgcc-file-name`
libgcc1-test.o: file not recognized: File format not recognized 
make: *** [libgcc1-test] Error 1
make: *** [all-gcc] Error 2
 (end logfile excerpt).
I used od to examine the first few bytes of libgcc1-test.o, and it 
is different from all the other .o files in the directory. 
Everything else starts with 014c 0005, but libgcc1-test.o begins 
with 6001 0400.
I'm at a bit of a loss as to how to proceed from here.  Can 
anyone shed any light on this for me?
For help on using this list, send a message to 
"" with one line of text: "help".
For help on using this list, send a message to
"" with one line of text: "help".

More information about the Cygwin mailing list